blockUI requires jQuery v1.2.3 or later! You are using v1.10.2
November 5, 2013 in Blog by
Are you having WordPress 3.7 jQuery Error? Don’t panic, everything will be just fine in just a moment. You don’t have to worry about downgrading either.
Basically your theme or plugins are using an older versions of jQuery and the developers need to update them.
We are going to get in to how to find where the problems is in just few moments but for now here is a solution that sometimes can make a quick fix for you.
You will need to install and activate jQuery Updater plugin this should fix the issue without any configuration. It actually has none so it made it really simple.
If this doesn’t help then let’s get in to pin pointing the problem so we can actually fix it without a band-aid.
Extra files in your plugin directory of your site are never good. Remember the more you make your visitors browser call for different files and make your server serve extra files the longer your web page takes to load.
When impatient visitors come to your site many will not wait past the 3 seconds before leaving your site.
Let’s move forward and clean this issue up.
Let’s start with your theme. Out of all the sites we had a problem with this was the biggest culprit.
If you have installed and activated jQuery Updater go ahead and deactivate it temporarily. Go to the front end of your site and you will see the error.
Now go to the admin panel and change your theme to Twenty Thirteen.
Navigate to the front end again to see if the error is gone, most likely it is.
If so change your theme back to the theme you normally use, activate jQuery Updater.
Now you can contact the developer of your theme to tell them about the issue.
If the error still occurs after the steps above, you need to deactivate plugins one by one until the error goes away.
Once it does you have pin pointed the plugin causing the issue.
Then follow the same steps in contacting the developers about the issue or in case update is available simply update it.
In my case I had to disable each plugin until the Chrome pop-up window with the “blockUI requires jQuery v1.2.3 or later! You are using v1.10.2″ error disappeared. Specifically it was a Calendar plugin that we were using that was causing the problem (All In One Event Calendar by Timely).
To fix it I simply installed Timely updater, which notified us that we were using a plugin version that was not being supported any longer and that we needed to update to the newer build. That fixed the issue and error message went away.
I hoped this helped, if you need any support feel contact us and we will fix your issue promptly!